Connexion
Pour récupérer votre compte, veuillez saisir votre adresse email. Vous allez recevoir un email contenant une adresse pour récupérer votre compte.
Inscription
En vous inscrivant, vous acceptez les conditions d'utilisation du site et de nous vendre votre âme pour un euro symbolique. Amusez vous, mais pliez vous à la charte.

Un Rédacteur Factornews vous demande :

Forums

Le topic de l'entraide Steam Deck (et surtout Linux)
Zaza le Nounours
Connard aigri
Admin 13504 msgs
Bonjoure.

Ici, je vous propose que l'on échange nos problèmes et difficultés constatés sur le Deck, et surtout que l'on y apporte des solutions dans une optique de partage des connaissances. On le fera de manière civilisée et courtoise, aucune insulte ne sera proférée à l'encontre de l'OS, de ses utilisateurs les plus dévoués ou même de leurs mères qui le jour de la conception auraient pourtant mieux fait de prendre dans le c-- ah ah pardon je m'emporte c'est NERVEUX. Civilisé et courtois, donc. Ah et bien sûr : installer une partition Windows ne sera jamais la solution, et oui c'est bien moi qui dis ça.

Je commence parce que évidemment je fais pas ça de manière complètement désintéressée. Je veux brancher mon Deck sur mon moniteur CRT parce que je suis une personne bizarre. Je passe par le dock officiel, et je relie mon moniteur au dock via un adaptateur DisplayPort-to-VGA. Je précise que cet écran et cet adaptateur marchent parfaitement sur mon gropécé Windows. Sur le Deck, ça "marche", j'ai bien une image, mais elle est en 640x480 et je ne peux pas changer la résolution, ni en game mode, ni en desktop mode.

J'ai fouillé un peu, j'ai trouvé la commande Xrandr, j'ai pu créer des résolutions custom et ça marche parfaitement (je suis présentement en train de taper ce message sur le Deck branché au moniteur avec une glorieuse résolution de 1024x768), mais quand je rebascule en game mode, la résolution custom est perdue et je reviens à du 640x480.

Du coup la question c'est : comment je fais pour entrer ces résolutions custom (800x600, 1024x768, 1280x960...) en dur et pouvoir ensuite les choisir dans les options de SteamOS, comme je peux le faire si je branche mon autre écran (34" uw) ou ma télé sur le dock ? Dans quel obscur fichier de conf il faut rentrer les résolutions pour que l'OS les connaisse pour de bon ?
 
Laurent
Membre Factor
Redac 3666 msgs
Voilà, tu as eu une réponse linuxienne typique en cas de problème : l'indifférence (voire le mépris).
Enfin c'était ça ou trois barbus se battant en duel à coup de solutions tordues toutes différentes censées pouvoir résoudre ton problème mais qui ne marchent pas chez toi.
 
BeatKitano
Bite qui tanne haut
Membre 6009 msgs

 
Message masqué
Mitaine
Membre Factor
Membre 249 msgs
Comme ça ?
Disclaimer : pas aussi barbu que ma photo le laisse penser.
 
BeatKitano
Bite qui tanne haut
Membre 6009 msgs

 
Message masqué
Zaza le Nounours
Connard aigri
Admin 13504 msgs
BeatKitano a écrit :
En fait j'ai vu le post le jour ou il a été créé, mais vu le ton j'ai attendu, pensant qu'il y avait bien quelqu'un avec peu d'amour propre pour offrir une solution qui marche pas vraiment... Et là je me serais impliqué pour aider.

Mdr "le ton", genre parce que je suis pas allé littéralement sucer la bite à Torvalds et implorer son pardon en me faisant tatouer son nom ainsi que celui de sa distro préférée sur le gland, j'emploie pas le bon ton. T'es dans l'espace, gars.

Mais en fait y'a eu un mec qui vient rajouter une couche de sciure sur la pizza au caca donc bah en fait:

Bonne chance.

Donc t'as servi à rien, t'as juste été pédant comme d'habitude. Viens pas te demander pourquoi tout le monde déteste les linuxiens, et toi en particulier. Barre-oit.
 
Message masqué
Zaza le Nounours
Connard aigri
Admin 13504 msgs
Mitaine a écrit :
Comme ça ?

Tout ce que fait le gars initial, je l'ai fait, ça marche. Par contre si j'essaye autre chose, comme par exemple (essayer d')installer arandr, je me fais jeter direct au moment de la récupération du package et je suis donc pas plus avancé. Quand j'ai essayé la méthode avec la création du fichier 10-my-monitor.conf, j'ai complètement brické mon Deck et j'ai été obligé de passer par une restore système avec le recovery en USB (heureusement j'ai pas tout perdu).
 
Zaza le Nounours
Connard aigri
Admin 13504 msgs
Fin de l'histoire, j'ai pris un autre adaptateur, qui fait VGA-to-HDMI plutôt que VGA-to-DP, et ça marche parfaitement, j'ai toutes les résolutions que prend mon CRT.
 
Zaza le Nounours
Connard aigri
Admin 13504 msgs
"Fin de l'histoire", qu'il disait, le con. 24 heures plus tard, alors que rien n'a changé depuis hier, que je n'ai même pas touché au Deck de la journée, avec le même cable, le même adaptateur, le même écran, le même Deck, le même réseau... ça remarche plus. Retour à du 640x480 or gfy.

Je vais pas vous dire le fond de ma pensée parce que la courtoisie, tout ça, mais putain. Quand même, hein.

Edit : ok alors en fait il faut que l'écran soit allumé et que ensuite seulement on branche le Deck. Dans ce sens-là, tout remonte bien. Je vais pas chercher à comprendre pourquoi, je resterai courtois et je le saurai pour les prochaines fois.
 
CBL
L.A.mming
Admin 17096 msgs
Ca a probablement à voir avec le fait que le EDID de l'écran doit être communiqué avant de pouvoir être utilisé. A l'époque des CRT c'etait courant devoir allumer le PC avant l'écran sous peine d'avoir des soucis avec certaines cartes graphiques. Je te laisse devenir la marque des cartes graphiques en question.
 
Zaza le Nounours
Connard aigri
Admin 13504 msgs
CBL a écrit :
Ca a probablement à voir avec le fait que le EDID de l'écran doit être communiqué avant de pouvoir être utilisé. A l'époque des CRT c'etait courant devoir allumer le PC avant l'écran sous peine d'avoir des soucis avec certaines cartes graphiques. Je te laisse devenir la marque des cartes graphiques en question.

Tu parles d'un temps où on roulait tous avec des CRT, donc ça devait être quoi, S3 ? Matrox ?

À moins que... non, quand même... déjà à l'époque ?
 
CBL
L.A.mming
Admin 17096 msgs
Zaza le Nounours a écrit :
À moins que... non, quand même... déjà à l'époque ?


Oh que oui. Particulièrement une certaine Rage 128...
 
Laurent
Membre Factor
Redac 3666 msgs
Mes chromebooks aussi ont toujours mieux aimé que j'allume le projo avant de les allumer, ça permettait de basculer l'écran principal auto sur le projo au lieu de le retrouver sur le chromebook et de devoir reswapper les écrans (surtout avec mon ancien en 720p).
 
BeatKitano
Bite qui tanne haut
Membre 6009 msgs
CBL: c'est un prb connu sur nvidia (a cause de leurs drivers) aussi quand on utilise l'HDMI, en DP pas de prb.
 
Zaza le Nounours
Connard aigri
Admin 13504 msgs
Ca remarche plus mdr. Comme d'habitude, rien n'a changé. Ecran allumé avant, après, reboot du Deck, débranché, rebranché, dans n'importe quel sens, par devant, par derrière : 640x480.

C'est vraiment un truc de terroristes, cet OS.
 
Zaza le Nounours
Connard aigri
Admin 13504 msgs
Quelques uns des liens sur lesquels je suis tombé :

https://wiki.archlinux.org/title/Kernel_mode_setting#Forcing_modes_and_EDID
https://wiki.archlinux.org/title/Kernel_parameters
https://www.reddit.com/r/archlinux/comments/oujnxs/new_amdgpu_unable_to_set_edid_on_one_monitor/
https://forum.level1techs.com/t/how-to-fix-no-edid-read-on-linux-5-6-0/156051

Je peux très certainement en sortir des dizaines d'autres. Evidemment rien de tout ça ne marche, parce que c'est incompréhensible, parce que dès la première étape (par exemple : créer un dossier "edid" dans "usr/lib/firmware") ça bloque, parce que la version de je sais pas quoi sur le Deck n'est pas exactement la même que celle pour laquelle une méthode très spécifique a été écrite.

Imaginez devoir subir ça pour, je le rappelle, brancher un écran. Imaginez y a des gens ils trouvent que c'est normal, ils trouvent que c'est ainsi que l'informatique doit fonctionner.

Je fais tous les efforts du monde pour rester courtois, mais y a des génocides qui ont été commis pour moins que ça.
 
BeatKitano
Bite qui tanne haut
Membre 6009 msgs

 
Message masqué
Chouf
Membre Factor
Membre 448 msgs
juste un mot pour soutenir l'avis de Zaza sur ce point :
Linux c'est bien pour faire des serveurs, mais quand il s'agit de coller un écran et du son dessus pour jouer/faire un HTPC, ça peut vite être le déclencheur d'une calvitie anticipée.
Quelle plaie ces drivers ALSA/pulse audio, Xrandr, etc. Ah et GRUB aussi...
Jamais un barbu ne s'est dit qu'il pouvait être le messie de l'OS en développant une GUI pour changer des paramètres de base autrement qu'en trifouillant des fichiers config ?
Mon ancien HTPC/Nas est devenue un simple Nas quand il a fallu passer à la 4K HDR et lui coller une CG : mon temps était devenue plus précieux que les 150€ pour une Shield TV.
 
Laurent
Membre Factor
Redac 3666 msgs
Non mais vous comprenez pas, les images et les GUI, c'est trop lent, le texte sur fond noir, ça va tellement plus vite à taper. Suffit de tout connaitre par coeur et voilà, c'est simple.
 
Nutz
Membre Factor
Membre 95 msgs
Ca ne donne pas super envie d'aider ce contexte mais concrètement quand l'écran est branché et allumé la commande

xrandr --props

Retourne quoi? (que l'affichage soit ok ou non)

Sinon ça peut paraître idiot mais la GUI elle ne vois pas du tout l'écran? Je connais pas le Deck mais me semble que c'est du KDE donc en cherchant le terme affichage dans le menu principal ça doit retourner le gestionnaire qui permet de tout configurer au clicodrome tant qu'il n'y a pas de soucis hardware (sauf que effectivement les EDID en VGA c'était la jungle et beaucoup de périphérique sont bugué)
 
Vous devez être connecté pour pouvoir participer à la discussion.
Cliquez ici pour vous connecter ou vous inscrire.

Règles à suivre

Écrire dans un français correct et lisible : ni phonétique, ni style SMS. Le warez et les incitations au piratage sont interdits. La pornographie est interdite. Le racisme et les incitations au racisme sont interdits. L'agressivité envers d'autres membres, les menaces, le dénigrement systématique sont interdits. Éviter les messages inutiles

 
Rechercher sur Factornews